Welcome to the Global Classroom Support Center!

Stay updated with announcements, get answers from the Global Classroom community, and share your feature suggestions with us.
You can also submit a request, report a bug, or send tech support an email at studentservices@globalclassroom.us.

 
 

Global Classroom Support

GC Tech Support April 30, 2013 2 Technical Questions & Answers (FAQ)

 

 

Recommended HTML5 Compliant Browsers

The following browsers have been tested to support the Global Classroom platform.  Minor visual differences may occur depending on the specific technologies supported by each browser, although functionality should be unaffected.  Click any of the links below to upgrade to the latest version for your operating system:

Internet Explorer users of older versions (6,7,8) should install the Chrome Frame plugin for full HTML5 support.

Older Browsers

Are you stuck on an older version of Internet Explorer because of company policy?  Not to fear, Global Classroom supports Google's Chrome Frame plugin to offer a first-class experience to users of all versions of Internet Explorer.  Just click below to install Chrome Frame and enjoy full HTML5 support! (No special permissions are needed for installation.)

A special no-installation version of Firefox is also available for Windows users who prefer Firefox instead of Chrome for HTML5 compatibility:

Recommended Browser Settings

Recommended Browser Plugins

The growing use of HTML5 technology is increasingly eliminating the need to install 3rd party plugins in order to access content on our platform, although legacy content may still use older technologies such as Flash.  For the best results, we recommend installing the following plugins on your PC:

GC Tech Support April 30, 2013 Technical Questions & Answers (FAQ)

Minimum System Requirements

The Global Classroom platform is built on the open standards of the Internet and requires a modern HTML5 compliant browser in order to operate. Here are the recommended minimum requirements, although the platform will still function with less.

  • HTML5 Capable Web Browser (see Recommended Browsers)
  • 500MHz CPU
  • 512MB RAM
  • 1Mbps Internet Connection
  • Internet Explorer users must use version 8 or above, and are strongly recommended to install this plugin from Google for full HTML5 support.

Recommended System Specifications

  • Recommended HTML5 Web Browser
  • 1GHz Dual-core CPU (for smooth video)
  • 1GB RAM
  • 3Mbps Wired Internet Connection
    (Wireless Internet may lead to a sporadic media experience depending on your local conditions)